CuBox Development Platform

Linux, Android based tiny, energy efficient development machine
It is currently Tue Sep 02, 2014 11:31 am

All times are UTC




Post new topic Reply to topic  [ 90 posts ]  Go to page Previous  1 ... 3, 4, 5, 6, 7, 8, 9  Next
Author Message
PostPosted: Sun Apr 22, 2012 6:09 pm 
Offline

Joined: Tue Dec 20, 2011 11:31 am
Posts: 135
Have anyone tried to compile XBMC for the CuBox from the very latest XBMC mainline upstream?

https://github.com/xbmc/xbmc/
Code:
git clone git://github.com/xbmc/xbmc/

merge to update rabeeh's fork
https://github.com/rabeeh/xbmc
Code:
git clone git://github.com/rabeeh/xbmc/

Would be interesting to test since they have updated FFmpeg and added a few more ARM fixes
https://github.com/xbmc/xbmc/commits/master


Top
 Profile  
 
PostPosted: Sun Apr 22, 2012 7:01 pm 
Offline

Joined: Sun Apr 15, 2012 10:21 am
Posts: 4
ntherning wrote:
Finally, XBMC seems to consume a lot of CPU even when idle. It's constantly using around 50%-60% when just displaying the home screen (confluence skin, no RSS feed). Is that expected?


The fix is to enable dirty region processing in XBMC: http://wiki.xbmc.org/index.php?title=Dirty_regions. With this turned on XBMC consumes a lot less CPU when idle. It seems to be more like 0%-10% now.


Top
 Profile  
 
PostPosted: Sun Apr 22, 2012 7:31 pm 
Offline
User avatar

Joined: Mon Jan 02, 2012 5:34 pm
Posts: 110
Location: Czech Republic
dirty regions have been discussed here: viewtopic.php?f=12&t=195
RockerC can You please add it to wiki?

_________________
Please visit and update the Wiki
Use forum Search function


Top
 Profile  
 
PostPosted: Sun Apr 22, 2012 9:13 pm 
Offline
SolidRun Staff

Joined: Wed Dec 14, 2011 11:20 pm
Posts: 477
RockerC - do you know if dirt regions is also active in video playback time?

this is one major issue we still have; although the video engine is very much capable of decoding very high bitrates, it becomes crippled in playback since GPU renders blank screen with 100% transparency (alpha blending) all the time, thus taking lots of CPU and DDR throughput, that can be used for video decoder.

http://www.solid-run.com/mw/index.php/B ... developers
Item #13

_________________
SolidRun Engineering
user rabeeh in #cubox on Freenode IRC
Please visit and update the Wiki


Top
 Profile  
 
PostPosted: Mon Apr 23, 2012 1:05 pm 
Offline

Joined: Tue Dec 20, 2011 11:31 am
Posts: 135
Best would be for SolidRun to submit all and any changes to XBMC source code as patches via pull requests upstream to XBMC.

That way all code such as the GStreamer played could be merged into mainline XBMC, which means that we could build XBMC from their official reposiroty instead of from a fork, and we would get help from their developers on any issues.

rabeeh wrote:
RockerC - do you know if dirt regions is also active in video playback time?
Dirty regions does not affect video playback at all. Dirty regions only affects the GUI / skins / menus, buttons, etc., so the only thing affected during video playback is the OSD (On Screen Display) menu if and when you bring that up.
http://wiki.xbmc.org/index.php?title=Dirty_regions
http://xbmc.org/theuni/2011/06/19/worki ... y-regions/

Sigi_cz wrote:
dirty regions have been discussed here: viewtopic.php?f=12&t=195
RockerC can You please add it to wiki?
Updated wiki http://www.solid-run.com/mw/index.php/X ... 9_for_XBMC


Top
 Profile  
 
PostPosted: Wed Apr 25, 2012 12:33 pm 
Offline

Joined: Thu Mar 08, 2012 10:58 am
Posts: 7
Is anyone having an issue with XBMC crashing when the TV is turned off?

Every time I am finished watching something and turn off my TV. I can see a few seconds in the log that XBMC crashes.
To me it looks like x-org is dies when it no longer detects the TV.

I will update with the logs later.


Top
 Profile  
 
PostPosted: Wed Apr 25, 2012 1:24 pm 
Offline

Joined: Thu Mar 08, 2012 7:09 am
Posts: 4
I'm having the same problem when the tv is turned off, does anybody know a solution for it?


Top
 Profile  
 
PostPosted: Thu Apr 26, 2012 12:44 pm 
Offline

Joined: Wed Mar 28, 2012 8:17 am
Posts: 8
Hi All,

I test the Enabling dirty regions (a.k.a. dirty textures) for XBMC and replace "1" with "3" when I play 1080p :o is ok now.

<advancedsettings>
<gui>
<algorithmdirtyregions>3</algorithmdirtyregions>
<nofliptimeout>1000</nofliptimeout>
</gui>
</advancedsettings>

Please test this settings
http://www.solid-run.com/mw/index.php/XBMC_on_CuBox

thanks.


Top
 Profile  
 
PostPosted: Sat Apr 28, 2012 11:19 pm 
Offline

Joined: Mon Apr 16, 2012 9:29 pm
Posts: 5
darraghw wrote:
Is anyone having an issue with XBMC crashing when the TV is turned off?

Every time I am finished watching something and turn off my TV. I can see a few seconds in the log that XBMC crashes.
To me it looks like x-org is dies when it no longer detects the TV.

I will update with the logs later.


Hi,

I have the same problem. Here is what happens when XBMC crashes (at least on my case);, xbmc.log;

Code:
00:55:37 T:1100893616   DEBUG: Checking repositories for updates (triggered by XBMC.org Add-ons)
00:55:37 T:1386312768   DEBUG: Thread Jobworker start, auto delete: 1
00:55:37 T:1386312768   DEBUG: CFileCache::Open - opening <addons/eden-pre/addons.xml.md5> using cache
00:55:37 T:1386312768   DEBUG: SECTION:LoadDLL(libcurl-gnutls.so.4)
00:55:37 T:1386312768   DEBUG: Loading: libcurl-gnutls.so.4
00:55:37 T:1386312768   DEBUG: FileCurl::Open(0x1a87d30) http://mirrors.xbmc.org/addons/eden-pre/addons.xml.md5
00:55:37 T:1386312768    INFO: easy_aquire - Created session to http://mirrors.xbmc.org
00:55:37 T:1394701376   DEBUG: Thread XFILE::CFileCache start, auto delete: 0
00:55:37 T:1394701376   DEBUG: Thread XFILE::CFileCache 1394701376 terminating
00:55:38 T:1386312768   DEBUG: CFileCache::Open - opening <svnroot/xbmcaeonmq/addons.xml.md5> using cache
00:55:38 T:1386312768   DEBUG: FileCurl::Open(0x167c880) https://xbmcaeonmq.svn.sourceforge.net/svnroot/xbmcaeonmq/addons.xml.md5
00:55:38 T:1386312768    INFO: easy_aquire - Created session to https://xbmcaeonmq.svn.sourceforge.net
00:55:40 T:1394701376   DEBUG: Thread XFILE::CFileCache start, auto delete: 0
00:55:40 T:1394701376   DEBUG: Thread XFILE::CFileCache 1394701376 terminating
00:55:41 T:1386312768   ERROR: ADDON: extension 'downloader/' is not currently supported for service addon

And on xorg log:
Code:
xbmc.bin: AddonInstaller.cpp:262: bool CAddonInstaller::CheckDependencies(const ADDON::AddonPtr&): Assertion `addon.get()' failed


I think new XBMC (latest version) is needed


Top
 Profile  
 
PostPosted: Wed May 02, 2012 7:17 am 
Offline

Joined: Sun Apr 15, 2012 10:21 am
Posts: 4
darraghw wrote:
Is anyone having an issue with XBMC crashing when the TV is turned off?

Every time I am finished watching something and turn off my TV. I can see a few seconds in the log that XBMC crashes.
To me it looks like x-org is dies when it no longer detects the TV.

I will update with the logs later.


I think I had the same problem. Turned out that my Logitech Harmony remote sends the Power signal to the cubox when I press the power button on the remote to turn off the TV and receiver. I had to comment out the line for the Power signal in /usr/share/lirc/remotes/mceusb/lircd.conf.mceusb. It wasn't enough just to remove the <power> entry in XBMC's Lircmap.xml. After restarting lircd and XBMC the XBMC process doesn't quit any more when I turn off the TV.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 90 posts ]  Go to page Previous  1 ... 3, 4, 5, 6, 7, 8, 9  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


phpBB SEO